เรียนรู้พื้นฐานคอมพิวเตอร์เครือข่าย
ฉบับเรียนรู้ด้วยตัวเอง VDO Traning Network
Network training
อบรม Network คุ้มค่า..กว่า 100 ขั้นตอน
พร้อมแถมโปรแกรม Simulation สมจริง
ให้คุณอบรมเรียนรู้ Network ที่บ้านคุณ

เรียนรู้ Network พร้อมโปรแกรม Network Simulation สมจริงเสมือนอบรม Network ที่บ้านคุณ

รายละเอียดที่คุณจะก้าวกระโดดในการเรียนรู้ Network
001-เกริ่นนำ DataCommunication
002-ทำความรู้จักองค์ประกอบการสื่อสาร
003-ทำความรู้จัก Direction dataflow
004-ทำความรู้จัก type of connection
005-เกริ่นนำมาตรฐานของ network
006-แนะนำพื้นฐานอุปกรณ์เครือข่าย
007-เรียนรู้ Lan Cable UTP&RJ45
008-เรียนรู้ LAN Cable 568B
009-ทำความรู้จัก LAN CROSS CABLE
010-ทำความรู้จัก fiber-optic
011-ตอนเกริ่นนำเรื่อง LAN
012-ตอนทำความรู้จัก Network topology
013-ตอน BASIC WIRELESS LAN
014-ตอนทำความรู้จัก bandwidth
015-ตอนทำความรู้จัก OSI model
016-ตอนทำความรู้จัก OSI Layer 1
017-ตอนทำความรู้จัก OSI Layer 2
018-ตอนทำความรู้จัก OSI Layer 3
019-ตอนทำความรู้จัก OSI Layer 4
020-ตอนทำความรู้จัก OSI Layer 5
021-ตอนทำความรู้จัก OSI Layer 6
022-ตอนทำความรู้จัก OSI Layer 7
023-เกริ่นนำ TCP IP
024-ตอนเรียนรู้ TCP IP LAYER
025-ตอนเรียนรู้ TCP IP Internet Layer
026-ตอนเรียนรู้ TCP IP internet protocol
027-ตอนเรียนรู้ TCP IP icmp
028-ตอนเรียนรู้ TCP IP transport
029-ตอนเรียนรู้ TCP IP udp
030-ตอนเรียนรู้ TCP IP tcp protocol
031-ตอนเรียนรู้ TCP IP TCP
032-ตอนเรียนรู้ TCP IP Application Layer
033-ตอนเรียนรู้ TCP IP threeway
034-ตอนเรียนรู้ Encapsulation Demultiplexing
035-ตอน ทำความรู้จัก IP Address
036-ตอน ทำความรู้จัก Public IP
037-ตอน ทำความรู้จัก Private IP
038-ตอนทำความรู้จัก VLSM
039-ตอนทำความรู้จัก CIDR
040-ตอนทำความรู้จัก Boardcast network
041-ตอนทำความรู้จัก collision domain
042-ตอนเรียนรู้ ประวัติเครือข่าย ethernet
043-ตอนเรียนรู้ มาตรฐาน IEEE
044-ตอนเรียนรู้ สถาปัตยกรรม IEEE ethernet
045-ตอนเรียนรู้ IEEE Datalink layer
046-ตอนเรียนรู้ IEEE Logical link control
047-ตอนเรียนรู้ IEEE Media Access control
048-ตอนเรียนรู้ IEEE ฟอร์แม็ตเฟรมข้อมูล
049-ตอนเรียนรู้ IEEE CSMA CD
050-ตอนเรียนรู้ IEEE Physical
051-แนะนำเครือข่ายแบบ 10Base2
052-แนะนำเครือข่ายแบบ 10BASE5
053-แนะนำเครือข่ายแบบ 10BaseT
054-แนะนำเครือข่ายแบบ 100BASE-FX
055-แนะนำเครือข่ายแบบ 100BASE-T4
056-แนะนำเครือข่ายแบบ 100BASE-TX
057-แนะนำเครือข่ายแบบ 1000BASE-CX
058-แนะนำเครือข่ายแบบ 1000BASE-LX
059-แนะนำเครือข่ายแบบ 1000BASE-SX
060-แนะนำเครือข่ายแบบ 10Giagabit
061-ตอนเกริ่นนำ cisco ios software
062-ตอน install program packettracer
063-ตอน Cisco Packet Tracer Overview
064-ตอนทำความรู้จักกับสัญลักษณ์ cisco network
065-ตอนวางอุปกรณ์ลง workspace
066-ตอนเรียนรู้ HUB
067-ตอนทดลองทำ HUB Simuration
068-ตอนทดลองทำ HUB Simuration เชื่อมต่อสายสัญญาณ
069-ตอนทดลองทำ HUB Simuration ดูเฟรมข้อมูล
070-ตอนการกำหนด ip ให้กับ pc
071-ตอน ทำความรู้จัก Network ID และ Broardcast ID
072-ตอน การสื่อสาร Network ID ที่แตกต่างกัน
073-ตอนแนะนำ cisco switch
074-ตอนเรียนรู้ switch cut throught
075-ตอนเรียนรู้ Switch store forwarding
076-ตอนเรียนรู้ Switch fragment free
077-ตอนทำความรู้จัก VLAN
078-ตอนทำความรู้จัก vlan trunk port
079-ตอนเรียนรู้ Mac address table
080-ตอนเรียนรู้ port base vlan
081-ตอนเรียนรู้ mac base vlan
082-ตอนเรียนรู้ ip base vlan
083-ตอนเรียนรู้ protocol type base vlan
084-ตอนเรียนรู้ spanning tree BPDU
085-ตอนเรียนรู้ spanning tree protocol
086-ตอนเรียนรู้มาตรฐาน VLAN
087-ตอนเรียนรู้ ARP Protocol
088-ตอน vlan simuration Lab01
089-ตอน vlan simuration Lab02
090-ตอน vlan simuration Lab03
091-ตอน vlan simuration Lab04
092-ตอน vlan simuration Lab05
093-ตอน vlan simuration Lab06
094-ตอน vlan simuration Lab07
095-ตอน vlan simuration Lab08
096-ตอน vlan simuration Lab09
097-ตอน vlan simuration Lab10
098-ตอน vlan simruation Lab11
099-ตอน vlan simuration Lab12
100-ตอน vlan simuration Lab13
101-ตอน vlan simuration Lab14
102-ตอน vlan simuration Lab15
103-ตอนทำความรู้จัก VTP
104-ตอน vlan simuration Lab VTP server
105-ตอน vlan simuration Lab VTP Transparent
106-ตอนเรียนรู้ Cisco Hardware router
107-ตอนเรียนรู้ Cisco Console port
108-ตอนเรียนรู้ router serail wan connection
109-ตอนเรียนรู้ PC connection to console port router
110-ตอนเรียนรู้ router startup
111-ตอนเรียนรู้ Routing protocol
112-ตอนเรียนรู้ Prompt router
113-ตอนเรียนรู้ user exec command
114-ตอนเรียนรู้ privilage command
115-ตอนเรียนรู้ show command
116-ตอนเรียนรู้ cisco password
117-ตอนเรียนรู้ cisco config password lab
118-ตอนเรียนรู้ router lab01
119-ตอนเรียนรู้ router lab02
120-ตอนเรียนรู้ router lab03
121-ตอนเรียนรู้ router cdp lab
122-ตอนเรียนรู้ Autonomus system
123-Configuration router แบบ Static Router Lab
124-Configuration router แบบ Default Router Lab
125-Configuration routerแบบ RIP Lab
126-Configuration router แบบ Eigrp Lab

เกริ่นนำเครือข่าย LAN คืออะไร
เป็นลักษณะการเชื่อมต่อเครือข่ายคอมพิวเตอร์ถึงกันภายในพื้นที่ใกล้ ๆ
กันไม่เกิน 100 เมตร เครือข่าย LAN ออกแบบมาเพื่อให้บริการแลกเปลี่ยนข่าวสารกัน
ในส่วนต่างๆขององค์กรในบริเวณที่ไม่ไกลกันมาก เช่นอยู่ในอาคารเดียวกัน
ระหว่างชั้นอาคาร สามารถดูแลได้เองโดยไม่ต้องใช้ระบบสื่อสารข้อมูลแบบอื่น



ความหมายของระบบเครือข่าย คือ
ระบบที่มีการนำคอมพิวเตอร์อย่างน้อยสองเครื่องมาเชื่อมต่อกัน
โดยใช้สื่อกลาง เพื่อใช้ในการสื่อสารข้อมูลถึงกันได้อย่างมีประสิทธิภาพ
ซึ่งทำให้ผู้ใช้คอมพิวเตอร์แต่ละเครื่องสามารถใช้แลกเปลี่ยนข้อมูลซึ่งกันและกันได้
นอกจากนี้ยังสามารถใช้ทรัพยากรร่วมกัน ทำให้ประหยัดทรัพยากรในการใช้งาน
เช่น printer, harddisk, CD ROM, Scanner เป็นต้น
ระบบเครือข่าย ที่เป็นที่นิยมเชื่อมต่อในระยะใกล้
ได้แก่ ระบบแลน (LAN : Local Area Network)
ระบบเครือข่าย ที่เป็นที่นิยมเชื่อมต่อระยะไกล
ได้แก่ ระบบแวน (WAN : Wide Area Network)





เรียนรู้พื้นฐาน Network ฉบับเรียนรู้ด้วยตัวเอง ตอน Lan Cable UTP&RJ45


เรียนรู้พื้นฐาน Network ฉบับเรียนรู้ด้วยตัวเอง ตอน LAN Cable 568B


เรียนรู้พื้นฐาน Network ฉบับเรียนรู้ด้วยตัวเอง ตอน LAN CROSS CABLE


เรียนรู้พื้นฐาน Network ฉบับเรียนรู้ด้วยตัวเอง ตอน BASIC WIRELESS LAN


เรียนรู้ปูพื้นฐานทำความเข้าใจ Network ด้วยตัวเอง ในราคาเพียง 200 บาท
กว่า 100 ขั้นตอนในการทำ LAB NETWORK เพื่อเข้าใจพื้นฐาน Network
พร้อมของแถมที่คุ้มค่าเพื่อคุณ ติดต่อ e-mail : prasan@prasansoft.com


พิเศษสุดสำหรับ ทุกท่านที่สั่งซื้อ E-book เตรียมสอบ CCNA Cisco
Software รูปแบบการสอบ CCNA
network training
Software รูปแบบการสอบ CCNA

network training
Lab & Diagram Network รูปแบบการสอบ CCNA

network training
Lab & Diagram Network รูปแบบการติวสอบ CCNA

network training
DataSheet ติวสอบ CCNA

network training
DataSheet ติวสอบ CCNA

network training
DataSheet ติวสอบ CCNA

network training


พร้อมตัวอย่างข้อสอบ พื้นฐานฟรีในแผ่น ครบครันครบเครื่องที่สุด
network training

network training

network training

network training

network training

network training

network training

network training

ตัวอย่างบางส่วนพร้อม e-book กว่า 20 เล่ม


เกริ่นนำเรื่องรูปทรง รูปแบบของเครือข่าย Network Topology

Bus Topology
การเชื่อมต่ออุปกรณ์ทั้งหมดโดยใช้สายเคเบิ้ลเพียงเส้นเดียว
สายเคเบิ้ลหลักจะต้องครอบปลายสายด้วย terminator
การเชื่อมต่อแบบนี้ เป็นการเริ่มต้นในช่วงต้น การพัฒนาระบบ LAN
ด้วยการใช้สายสัญญาณ โคแอ๊กเชียว ในปัจจุบันไม่นิยม

Ring Topology
การเชื่อมต่อแบบวงแหวนโดยที่คอมพิวเตอร์จะทำการเชื่อมต่อในลักษณะ
วงกลมเฟรมข้อมูลที่วิ่งอยู่ใน LAN จะวิ่งไปทิศทางเดียว
และหยุดเมื่อถึงปลายทางที่ต้องการ โดยอาศัยโทเคนหรือคิวในการส่งข้อมูล
ปัจจุบันไม่เป็นที่นิยมในการใช้งานเช่นเดียวกัน

Mesh Topology
เป็นรูปแบบการเชื่อมต่ออุปกรณ์ทุกตัวเข้าด้วยกัน
เพื่อทำให้เกิดการซ้ำซ้อน redundancy ซึ่งจะทนต่อ
การล้มเหลวในการรับส่งข้อมูลนั่นเอง รูปทรงแบบนี้ก็ยังคงใช้งานอยู่
แต่จะนำไปใช้งานในระบบ WAN

Full Mesh
เป็นวิวัฒนาการต่อเนื่องมาจากแบบ mesh จุดประสงค์ก็คือการการันตี
ว่าเครื่องคอมพิวเตอร์ สามารถที่จะส่งข้อมูลกันได้นั่นเอง
ซึ่งก็ยังไม่ได้รับความนิยม เนื่องจากการใช้สายสัญญาณ
ที่มากอุปกรณ์ที่มากและสิ้นเปลือง

Star Topology
เป็นรูปแบบที่นิยมใช้งานมากที่สุด มีข้อดีที่มากกว่าข้อเสีย
ใช้ในระบบ LAN ปัจจุบันคุณภาพมากกว่าทุก topology ที่กล่าวมา



เกริ่นนำ OSI Model คืออะไร
เรียนรู้ OSI model ที่มาและความสำคัญในการแยกย่อยเครือข่าย
และจัดระเบียบการเรียนรู้ออกเป็น layer ย่อยๆดังนี้

-Layer 7 Application layer
-Layer 6 Presentation layer
-Layer 5 Session layer
-Layer 4 Transport layer
-Layer 3 Network layer
-Layer 2 Data link layer
-Layer 1 physical layer


เกริ่นนำ OSI Layer1


เกริ่นนำ OSI Layer2

โครงสร้างของสถาปัตยกรรมรูปแบบ OSI
สามารถการแบ่งออกเป็น 7 เลเยอร์
และในแต่ละเลเยอร์ได้มีการกำหนดหน้าที่การทำงานไว้ดังต่อไปนี้

1.เลเยอร์ชั้น Physical
เป็นชั้นล่างสุดของการติดต่อสื่อสาร ทำหน้าที่ส่ง-รับข้อมูลจริง ๆ
จากช่องทางการสื่อสาร (สื่อกลาง) ระหว่างคอมพิวเตอร์เครื่องหนึ่งกับคอมพิวเตอร์เครื่องอื่น ๆ
มาตรฐานสำหรับเลเยอร์ชั้นนี้จะกำหนดว่าแต่ละคอนเนคเตอร์ (Connector) เช่น RS-232-C
มีกี่พิน (PIN) แต่ละพินทำหน้าที่อะไรบ้าง ใช้สัญญาณไฟกี่โวลต์
เทคนิคการมัลติเพล็กซ์แบบต่าง ๆ ก็จะถูกกำหนดอยู่ในเลเยอร์ชั้นนี้
ซึ่งทำให้ผู้ใช้คอมพิวเตอร์แต่ละเครื่องสามารถใช้แลกเปลี่ยนข้อมูลซึ่งกันและกันได้

2. เลเยอร์ชั้น Data Link
จะเป็นเสมือนผู้ตรวจสอบ หรือควบคุมความผิดพลาดในข้อมูล
โดยจะแบ่งข้อมูลที่จะส่งออกเป็นแพ็กเกจหรือเฟรม
ถ้าผู้รับได้รับข้อมูลถูกต้องก็จะส่งสัญญาณยืนยันกลับว่าได้รับข้อมูลแล้ว
เรียกว่าสัญญาณ ACK (Acknowledge) ให้กับผู้ส่ง แต่ถ้าผู้ส่งไม่ได้รับสัญญาณ ACK
หรือได้รับสัญญาณ NAK (Negative Acknowledge) กลับมา
ผู้ส่งก็อาจจะทำการส่งข้อมูลไปให้ใหม่ อีกหน้าที่หนึ่งของเลเยอร์ชั้นนี้คือ
ป้องกันไม่ให้เครื่องส่งทำการส่งข้อมูลเร็วจนเกิดขีดความสามารถ
เครื่องผู้รับจะรับข้อมูลได้

3. เลเยอร์ชั้น Network
เป็นชั้นที่ออกแบบหรือกำหนดเส้นทางการเดินทางของข้อมูลที่ส่ง-รับในการส่งผ่าน
ข้อมูลระหว่างต้นทางและปลายทาง
ซึ่งแน่นอนว่าในการสื่อสารข้อมูลผ่านเครือข่ายการสื่อสาร
จะต้องเส้นทางการรับ-ส่งข้อมูลมากกว่า 1 เส้นทาง ดังนั้นเลเยอร์ชั้น Network
นี้จะมีหน้าที่เลือกเส้นทางที่ใช้เวลาในการสื่อสารน้อยที่สุด และระยะทางสั้นที่สุดด้วย
ข่าวสารที่รับมาจากเลเยอร์ชั้นที่ 4 จะถูกแบ่งออกเป็นแพ็กเกจ ๆ ในชั้นที่ 3 นี้

4. เลเยอร์ชั้น Transport
บางครั้งเรียกว่า เลเยอร์ชั้น Host-to-Host หรือเครื่องต่อเครื่อง
และจากเลเยอร์ชั้นที่ 4 ถึงชั้นที่ 7 นี้รวมกันจะเรียกว่า
เลเยอร์ End-to-End ในเลเยอร์ชั้น Transport
นี้เป็นการสื่อสารกันระหว่างต้นทางและปลายทาง (คอมพิวเตอร์กับคอมพิวเตอร์) กันจริง ๆ
เลเยอร์ชั้น Transport จะทำหน้าที่ตรวจสอบว่าข้อมูลที่ส่งมาจากเลเยอร์ชั้น Session
นั้นไปถึงปลายทางจริง ๆ หรือไม่ ดังนั้นการกำหนดตำแหน่งของข้อมูล (Address)
จึงเป็นเรื่องสำคัญในชั้นนี้ เนื่องจากจะต้องรับรู้ว่าใครคือผู้ส่ง และใครคือผู้รับข้อมูลนั้น

5. เลเยอร์ชั้น Session
ทำหน้าที่เชื่อมโยงระหว่างผู้ใช้งานกับคอมพิวเตอร์เครื่องอื่น ๆ
โดยผู้ใช้จะใช้คำสั่งหรือข้อความที่กำหนดไว้ป้อนเข้าไปใน ระบบ
ในการสร้างการเชื่อมโยงนี้ผู้ใช้จะต้องกำหนดรหัสตำแหน่งของจุดหมายปลายทาง
ที่ต้องการติดต่อสื่อสารด้วย เลเยอร์ชั้น Session จะส่งข้อมูล ทั้งหมดให้กับเลเยอร์ชั้น
Transport เป็นผู้จัดการต่อไป ในบางเครือข่ายทั้งเลเยอร์ Session
และเลเยอร์ Transport อาจจะเป็นเลเยอร์ชั้นเดียวกัน

6. เลเยอร์ชั้น Presentation
ทำหน้าที่เหมือนบรรณารักษ์ กล่าวคือคอยรวบรวมข้อความ (Text) และแปลงรหัส
หรือแปลงรูปของข้อมูล ให้เป็นรูปแบบการสื่อสารเดียวกัน เพื่อช่วยลดปัญหาต่าง ๆ
ที่อาจจะเกิดขึ้นกับผู้ใช้งานในระบบ

7. เลเยอร์ชั้น Application
เป็นเลเยอร์ชั้นบนสุดของรูปแบบ OSI ซึ่งเป็นชั้นที่ใช้ติดต่อกันระหว่างผู้ใช้โดยตรงซึ่ง
ได้แก่ โฮสต์คอมพิวเตอร์ เทอร์มินัลหรือคอมพิวเตอร์ PC เป็นต้น
แอปพลิเคชันในเลเยอร์ชั้นนี้สารมารถนำเข้า หรือออกจากระบบเครือข่าย
ได้โดยไม่จำเป็นต้องสนใจว่า จะมีขั้นตอนการทำงานอย่างไร
เพราะจะมีเลเยอร์ชั้น Presentation เป็นผู้รับผิดชอบแทนอยู่แล้ว
ในรูปแบบ OSI เลเยอร์นั้น Application จะทำการติดต่อกับเลเยอร์
ชั้น Presentation โดยตรงเท่านั้น โปรโตคอลของในแต่ละชั้น
จะแตกต่างกันออกไป แต่อย่างไรก็ตามการที่เครื่องคอมพิวเตอร์




ศึกษาเรื่อง Networking กับอุปกรณ์ Cisco IOS Network
ด้วยโปรแกรม Cisco Packet Tracer


อุปกรณ์ของ CISCO นั้นเป็นอุปกรณ์ที่ Management ได้เราสามารถปรับแต่ง ได้จาก Command

ที่มีอยู่ภายในระบบปฎิบัติการ IOS ของ CISCO เอาเป็นว่าสำหรับผู้เริ่มต้นเรียนรู้ Management

ทางด้าน Network แล้วกันนะครับ ภาพแสดงอุปกรณ์ที่จะใช้ทำการ Configure


Diagram Network เราจะทำการเชื่อมต่อ Router1 และ Router2



พร้อมทั้งเตรียมพร้อมการทำงาน เรียกว่ากระตุ้นการทำงานของ interface ทั้ง 2 ฝั่ง

ด้วยคำสั่ง no shut ท ี่Router1 interface serial0/0 และ
เช่นกันที่ Router 2 interface serial0/1 ซึ่งเชื่อมต่อกันด้วย สาย serial

เราจะใช้ command ในการทดลองนี้ดังนี้

สถานะ promt ของ Router คำสั่งที่ใช้ในในการทดลองนี้ ความหมายของคำสั่ง
Router> enable เข้าไปยัง Router
Router# configure terminal
เข้าสู่โหมด privilege
Router(config)# hostname Router2
เปลี่ยนชื่อของ Router
Router(config)# interface serial 0/1
ติดต่อกับ interface serail หมายเลข port 0/1
Router(config-if)# no shut
กระตุ้นหรือการเปิดการทำงานของ interface





ภาพแสดงการ Configure ที่ Console

คำสั่งที่เราต้องการเปิดให้ Router ทำงานต้องจัดคำสั่งเป็น Step นะครับ

 

การ Configure ที่ router 1

 

Restricted Rights Legend

Use, duplication, or disclosure by the Government is
subject to restrictions as set forth in subparagraph
(c) of the Commercial Computer Software - Restricted
Rights clause at FAR sec. 52.227-19 and subparagraph
(c) (1) (ii) of the Rights in Technical Data and Computer
Software clause at DFARS sec. 252.227-7013.

cisco Systems, Inc.
170 West Tasman Drive
San Jose, California 95134-1706

 

Cisco Internetwork Operating System Software
IOS (tm) C2600 Software (C2600-I-M), Version 12.2(28), RELEASE SOFTWARE (fc5)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2005 by cisco Systems, Inc.
Compiled Wed 27-Apr-04 19:01 by miwang

cisco 2620 (MPC860) processor (revision 0x200) with 60416K/5120K bytes of memory
.
Processor board ID JAD05190MTZ (4292891495)
M860 processor: part number 0, mask 49
Bridging software.
X.25 software, Version 3.0.0.
1 FastEthernet/IEEE 802.3 interface(s)
2 Low-speed serial(sync/async) network interface(s)
32K bytes of non-volatile configuration memory.
16384K bytes of processor board System flash (Read/Write)

--- System Configuration Dialog ---

Continue with configuration dialog? [yes/no]: no

Press RETURN to get started!

 

Router>enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname Router1
Router1(config)#
Router1(config)#interface serial 0/0
Router1(config-if)#
Router1(config-if)#no shut

%LINK-5-CHANGED: Interface Serial0/0, changed state to up
Router1(config-if)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0, changed state to up


 

การ Configure ที่ router 2

 

 

Restricted Rights Legend

Use, duplication, or disclosure by the Government is
subject to restrictions as set forth in subparagraph
(c) of the Commercial Computer Software - Restricted
Rights clause at FAR sec. 52.227-19 and subparagraph
(c) (1) (ii) of the Rights in Technical Data and Computer
Software clause at DFARS sec. 252.227-7013.

cisco Systems, Inc.
170 West Tasman Drive
San Jose, California 95134-1706

 

Cisco Internetwork Operating System Software
IOS (tm) C2600 Software (C2600-I-M), Version 12.2(28), RELEASE SOFTWARE (fc5)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2005 by cisco Systems, Inc.
Compiled Wed 27-Apr-04 19:01 by miwang

cisco 2620 (MPC860) processor (revision 0x200) with 60416K/5120K bytes of memory
.
Processor board ID JAD05190MTZ (4292891495)
M860 processor: part number 0, mask 49
Bridging software.
X.25 software, Version 3.0.0.
1 FastEthernet/IEEE 802.3 interface(s)
2 Low-speed serial(sync/async) network interface(s)
32K bytes of non-volatile configuration memory.
16384K bytes of processor board System flash (Read/Write)

--- System Configuration Dialog ---

Continue with configuration dialog? [yes/no]: no

Press RETURN to get started!

 

Router>enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname Router2
Router2(config)#
Router2(config)#interface serial 0/1
Router2(config-if)#
Router2(config-if)#no shut

%LINK-5-CHANGED: Interface Serial0/1, changed state to up
Router2(config-if)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/1, changed state to up



ในขณะนี้สถานะของ Router ของเราได้ Up แล้ว เราสามารถใช้คำสั่ง Show ip int Brief

เพื่อตรวจสอบสถานะการ Up ที่ serial interface0/0 ของ Router1



ภาพแสดงสถานะของ Router1 Serial0/0 สถานะ up



ภาพ แสดงสถานะของ Router2 Serial0/1 Up

นี่เป็นเพียงการเริ่มต้นการทำงานของ Router เท่านั้น ขั้นตอนต่อไปเรามาดู

การกำหนด Ip address ให้กับ interface ซึ่งเป็นค่า Gateway นั่นเอง


บทความเรื่อง Networking ด้วย Cisco


ในส่วนบทความนี้เราจะกำหนด IP address
ประจำ interface port เพื่อให้ Network ทำงานได้



Diagram Network เราจะทำการเชื่อมต่อ Router1 และ Router2




เราจะใช้ command ในการทดลองนี้ดังนี้

สถานะ promt ของ Router คำสั่งที่ใช้ในในการทดลองนี้ ความหมายของคำสั่ง
Router> enable เข้าไปยัง Router
Router# configure terminal
เข้าสู่โหมด privilege

Route

r(config)#

interface fastethernet0/0 ทำงานกับ interface fastethernet port0/0

Router

(config-if)#

ip address 192.168.1.1
255.255.255.0
กำหนด Ip address ให้กับ port interface fastethernet 0/0 มีค่าเท่ากับ 192.168.1.1 subnet mask 255.255.255.0

Router

(config-if)#

no shut
กระตุ้นหรือการเปิดการทำงานของ interface

Router

(config-if)#

interface serial 0/1 กำหนด IP address ประจำ port
interface serial port0/1 ของ WAN

Router

(config-if)#

ip address 10.82.1.1
255.255.255.0
ค่า Wan Ip address ที่กำหนดให้WAN

Router

(config-if)#

no shut
กระตุ้นหรือการเปิดการทำงานของ interface




คำสั่งที่เราต้องการเปิดให้ Router ทำงานต้องจัดคำสั่งเป็น Step นะครับ

การ Configure ที่ router 1

 

Router1>enable
Router1#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router1(config)#interface fastethernet0/0
Router1(config-if)#ip address 192.168.1.1 255.255.255.0
Router1(config-if)#no shut

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up


Router1(config-if)#exit
Router1(config)#exit

Router1(config)#interface serial 0/1
Router1(config-if)#
Router1(config-if)#ip address 10.82.1.1 255.255.255.0
Router1(config-if)#no shut

%LINK-5-CHANGED: Interface Serial0/1, changed state to down

การ Configure ที่ router 2

 

Router2>
Router2>enable
Router2#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router2(config)#
Router2(config)#interface fastethernet0/0
Router2(config-if)#ip address 192.168.2.1 255.255.255.0
Router2(config-if)#no shut

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
Router2(config-if)#


Router2(config-if)#exit
Router2(config)#exit
Router2#
Router2#enable
Router2#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router2(config)#interface serial0/0
Router2(config-if)#ip address 10.82.1.2 255.255.255.0
Router2(config-if)#no shut

%LINK-5-CHANGED: Interface Serial0/0, changed state to down
Router2(config-if)#


ตรวจสอบสถานะการ COnfiguration Fastehternet0/0 ของ Router1 และ

ตรวจสอบสถานะการ COnfiguration Fastehternet0/0 ของ Router2

ด้วยการใช้คำสั่ง Show Ip interface brief



ทำการทดลอง การเชื่อมต่อด้วย Diagram ในที่นี้ สามารถทดสอบได้

ด้วยการ Ping จาก PC ไปที่ Router เป็นลักษณะของการติดต่อ Gateway นั่นเอง




ทดสอบด้วย การ Ping Command ของ 192.168.1.2 ซึ่งเชื่อมต่อที่ router 1




ทดสอบด้วย การ Ping Command ของ 192.168.2.2 ซึ่งเชื่อมต่อที่ router 2




การกำหนด Ip address ให้กับ interface ซึ่งเป็นค่า Gateway นั่นเอง



ในส่วนบทความนี้เราจะกำหนด รหัสผ่านเพื่อป้องกันการ Login เข้าสู่ Router


การตั้งรหัสผ่าน สำหรับ Router มีความจำเป็นมาก สามารถป้องกัน

การ login เข้าสู่ Router จากผู้ที่ไม่ได้รับอนุญาติ

เราจะใช้ command ในป้องกัน การ Login ดังนี้

สถานะ promt ของ Router คำสั่งที่ใช้ในในการทดลองนี้ ความหมายของคำสั่ง
Router(config)# enable password conxx กำหนดรหัสผ่าน conxx
Router(config)# show running-config
ตรวจสอบการกำหนด password ที่ตัว Router




คำสั่งสั้นๆ แค่บรรทัดเดียวเท่านั้นครับ

การ Configure ที่ router

 

Router1(config)#
Router1(config)#enable password conxx
[เป็นการตั้งรหัสผ่านที่จะเข้าสู่โหมด privilege เพื่อตรวจสอบสิทธิ์การใช้งาน ]

 

Router1 con0 is now available

 

Press RETURN to get started.

           
Router1>enable

Password:
Router1#
Router1#
Router1#
[เมื่อกลับเข้าสู่การทำงานของ Router อีกครั้งจำเป็นที่จะต้องมีการยืนยันรหัสผ่าน ]

 

ทดสอบการเข้ารหัสด้วยคำสั่ง enable secret  

           
Router1(config)#enable secret xxxx
Router1(config)#exit
%SYS-5-CONFIG_I: Configured from console by console
Router1#
Router1#
Router1#
Router1#sh running-config
Building configuration...

Current configuration : 504 bytes
!
version 12.2
no service password-encryption
!
hostname Router1
!
!
enable secret 5 $1$mERr$2s5zEcQgIoJE5FtRk6Zt0.
enable password conxx
!
!
!
!
ip ssh version 1
!
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
shutdown
!
interface Serial1/0
no ip address
clock rate 56000
!
interface Serial1/1
no ip address
shutdown
!
interface Serial1/2
no ip address
shutdown
!
interface Serial1/3
no ip address
shutdown
!
ip classless
!
!
!
!
!
line con 0
line vty 0 4
login
!
!
end

เมื่อทำการดูข้อมูลจะปรากฎให้เห็นว่า คำสั่ง enable secret มีการเขารหัสเพื่อซ่อน password




หน้าที่หลักของ CDP คือ การส่งและรับข้อมูล configuration พื้นฐาน ของ Router เพื่อนบ้าน

เพื่อค้นหาสาเหตุเมื่อ Router ทำงานผิดปกติ



การตั้งรหัสผ่าน สำหรับ Router มีความจำเป็นมาก สามารถป้องกัน

การ login เข้าสู่ Router จากผู้ที่ไม่ได้รับอนุญาติ

เราจะใช้ command ในป้องกัน การ Login ดังนี้

สถานะ promt ของ Router คำสั่งที่ใช้ในในการทดลองนี้ ความหมายของคำสั่ง
Router(config)# interface serial 0/0
ติดต่อกับ interface serial0/0
Router(config)# no shut เปิดการทำงานของ interface
ที่เราทำงาน
Router(config)# clock rate 64000
การตั้งค่า Clockrate ของ router ฝั่ง
DTE
Router(config)# show ip int brief 
แสดงหมายเลข IP ของ router
Router(config)# sh cdp
 
แสดงระยะเวลาสำหรับ update
ข้อมูลระหว่างกันรวมถึง การ
update ข้อมูลของ CDP

Router(config)#

 

show cdp interface

 

 

แสดงข้อมูลของทุก interface

Router(config)# show cdp neighbors
แสดงข้อมูลของ Router
ที่เชื่อมต่ออยู่ โดยละเอียด




สามารถทำได้จาก Router ที่เชื่อมต่อกันอยู่ครับ เพื่อดูการรับส่งข้อมุล สถานะต่างๆ

การ Configure ที่ router

 

Router1(config)#interface serial 0/0
Router1(config-if)#no shut

%LINK-5-CHANGED: Interface Serial1/0, changed state to down
Router1(config-if)#
Router1(config-if)#clock rate 64000
Router1(config-if)#
Router1(config-if)#
%LINK-5-CHANGED: Interface Serial1/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial1/0, changed state to up

 

Router1#show ip int brief 

แสดงหมายเลข IP ของ router
Interface               IP-Address      OK? Method Status                Protocol

FastEthernet0/0   unassigned      YES manual administratively down down

Serial1/0              unassigned      YES manual up                    up

Serial1/1              unassigned      YES manual administratively down down

Serial1/2              unassigned      YES manual administratively down down

Serial1/3              unassigned      YES manual administratively down down



Router1#sh cdp
 [แสดงระยะเวลาสำหรับ update ข้อมูลระหว่างกันรวมถึง การ update ข้อมูลของ CDP]
Global CDP information:
Sending CDP packets every 60 seconds
Sending a holdtime value of 180 seconds

    Sending CDPv2 advertisements is enabled    




Router1#show cdp interface


แสดงข้อมูลของทุก interface
FastEthernet0/0 is administratively down, line protocol is down
Sending CDP packets every 60 seconds
Holdtime is 180 seconds
Serial0/0 is up, line protocol is up
Sending CDP packets every 60 seconds
Holdtime is 180 seconds
Serial0/1 is administratively down, line protocol is down
Sending CDP packets every 60 seconds
Holdtime is 180 seconds
Router1#

Router1#show cdp neighbors

แสดงข้อมูลของ Router ที่เชื่อมต่ออยู่ โดยละเอียด
Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
S - Switch, H - Host, I - IGMP, r - Repeater, P - Phone
Device ID    Local Intrfce   Holdtme    Capability   Platform    Port ID
Router2            Ser 1/0             133            R             C2600       Ser 1/0
Router1#



Device ID คือ ชื่อของ Router ที่เราใช้เชื่อมต่ออยู่
Local Interface คือ อินเตอร์เฟสที่เชื่อมต่อกัน
Holdtime คือ ระยะเวลาที่เราเตอร์ตั้งไว้
สำหรับแก้ปัญหาการแลกเปลี่ยนข้อมูลระหว่างกัน
ถ้าไม่มีการแลกเปลี่ยนข้อมูลเกินค่า Hold down timer นี้ R1
จะลบข้อมูลของเพื่อนบ้านออกจาก Routing table คือ 133 วินาที
Capability คือ R แสดงว่ากำลังรับข้อมูลจาก R
Platform คือ แสดงรุ่นของ Router เพื่อนบ้าน
Port ID คือ เป็น port เพื่อนบ้านใช้ในการเชื่อมต่อ ในที่นี้ ใช้ port  Ser 1/0






ในส่วนบทความนี้เราจะเรียนรู้พื้นฐานการกำหนด เส้นทางแบบ Static

เพื่อให้ Router สามารถสื่อสารกัับเครื่อข่ายผ่าน subnet ที่ต่างกันได้

Diagram Network เราจะทำการเชื่อมต่อ Router1 , Router2 , Router3

และทำการกำหนดเส้นทาง การเชื่อมต่อของเครือข่ายแบบ static




เราจะใช้ command เบื้องต้นเพื่อให้ router สื่อสารแบบ static ในการทดลองนี้ดังนี้

สถานะ promt ของ Router คำสั่งที่ใช้ในในการทดลองนี้ ความหมายของคำสั่ง
Router> enable เข้าไปยัง Router
Router# configure terminal
เข้าสู่โหมด privilege

Route

r(config)#

interface fastethernet0/0 ทำงานกับ interface fastethernet port0/0
(ต้องดำเนินการกำหนดค่า config ให้กับ router ทั้ง 3)

Router

(config-if)#

ip address 192.168.1.1
255.255.255.0
กำหนด Ip address ให้กับ port interface
fastethernet 0/0 มีค่าเท่ากับ 192.168.1.1
subnet mask 255.255.255.0
(ต้องดำเนินการกำหนดค่า config ให้กับ router ทั้ง 3 เป็น IP ประจำ interface fastethernet)

Router

(config-if)#

no shut
กระตุ้นหรือการเปิดการทำงานของ interface
(ต้องดำเนินการกำหนดค่า config ให้กับ router ทั้ง 3)

Router

(config-if)#

interface serial 0/1 กำหนด IP address ประจำ port
interface serial port0/1 ของ WAN
(ต้องดำเนินการกำหนดค่า config ให้กับ router ทั้ง 3)

Router

(config-if)#

ip address 10.82.1.1
255.255.255.0
ค่า Wan Ip address ที่กำหนดให้WAN
(ต้องดำเนินการกำหนดค่า config ให้กับ router ทั้ง 3)

Router

(config-if)#

clock rate 64000 กำหนด clock rate สำหรับ router (CDE)

Router

(config-if)#

no shut
กระตุ้นหรือการเปิดการทำงานของ interface
(ต้องดำเนินการกระตุ้น ให้กับ router ทั้ง 3)

Router1

(config)#

ip route 192.168.2.0
255.255.255.0
10.82.1.2
ทำการกำหนดเส้นทางการสื่อสารของ
Router 1 เพื่อให้ติดต่อกับ network ID
192.168.2.0 โดยผ่านประตูทางเข้า
10.82.1.2 ของ Router 2
เพื่อให้ Router 1 --> Router 2

Router1

(config)#

ip route 192.168.3.0
255.255.255.0
10.82.1.2
ทำการกำหนดเส้นทางการสื่อสารของ
Router 1 เพื่อให้ติดต่อกับ network ID
192.168.3.0 โดยผ่านประตูทางเข้า
10.82.1.2 ของ Router 2
เพื่อให้ Router 1 --> Router 3

Router2

(config)#

ip route 192.168.1.0
255.255.255.0
10.82.1.1
ทำการกำหนดเส้นทางการสื่อสารของ
Router 2 เพื่อให้ติดต่อกับ network ID
192.168.1.0 โดยผ่านประตูทางเข้า
10.82.1.1 ของ Router 1
เพื่อให้ Router 2 --> Router 1

Router2

(config)#

ip route 192.168.3.0
255.255.255.0
10.82.2.2
ทำการกำหนดเส้นทางการสื่อสารของ
Router 2 เพื่อให้ติดต่อกับ network ID
192.168.3.0 โดยผ่านประตูทางเข้า
10.82.2.2 ของ Router 3
เพื่อให้ Router 2 --> Router 3

Router3

(config)#

ip route 192.168.1.0
255.255.255.0
10.82.2.1
ทำการกำหนดเส้นทางการสื่อสารของ
Router 3 เพื่อให้ติดต่อกับ network ID
192.168.1.0 โดยผ่านประตูทางเข้า
10.82.2.1 ของ Router 3
เพื่อให้ Router 3 --> Router 1

Router3

(config)#

ip route 192.168.2.0
255.255.255.0
10.82.2.1
ทำการกำหนดเส้นทางการสื่อสารของ
Router 3 เพื่อให้ติดต่อกับ network ID
192.168.2.0 โดยผ่านประตูทางเข้า
10.82.2.1 ของ Router 3
เพื่อให้ Router 3 --> Router 2




คำสั่งที่เราต้องการเปิดให้ Router ทั้ง 3 มีขั้นตอนพื้นฐานดังนี้

การ Configure ที่ router 1

 

Router>
Router>enable
Router#
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#
Router(config)#hostname Router1
Router1(config)#
Router1(config)#interface fastethernet0/0
Router1(config-if)#
Router1(config-if)#ip address 192.168.1.1 255.255.255.0
Router1(config-if)#no shut

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
Router1(config-if)#exit
Router1(config)#
Router1(config)#interface serial0/0
Router1(config-if)#
Router1(config-if)#ip address 10.82.1.1 255.255.255.0
Router1(config-if)#clock rate 64000
Router1(config-if)#no shut

%LINK-5-CHANGED: Interface Serial0/0, changed state to down
Router1(config-if)#
Router1(config-if)#exit
Router1(config)#
Router1(config)#ip route 192.168.2.0 255.255.255.0 10.82.1.2
Router1(config)#ip route 192.168.3.0 255.255.255.0 10.82.1.2
Router1(config)#
Router1(config)#exit
%SYS-5-CONFIG_I: Configured from console by console
Router1#
Router1#
Router1#write memory
Building configuration...
[OK]
Router1#
Router1#


  การ Configure ที่ router 2
 

Router>
Router>enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#
Router(config)#hostname Router2
Router2(config)#
Router2(config)#interface fastethernet0/0
Router2(config-if)#
Router2(config-if)#ip address 192.168.2.1 255.255.255.0
Router2(config-if)#no shut

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
Router2(config-if)#
Router2(config-if)#exit
Router2(config)#
Router2(config)#interface serial 0/0
Router2(config-if)#ip address 10.82.1.2 255.255.255.0
Router2(config-if)#no shut

%LINK-5-CHANGED: Interface Serial0/0, changed state to up
Router2(config-if)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0, changed state to up
Router2(config-if)#
Router2(config-if)#exit
Router2(config)#
Router2(config)#interface serial0/1
Router2(config-if)#
Router2(config-if)#ip address 10.82.2.1 255.255.255.0
Router2(config-if)#clock rate 64000
Router2(config-if)#no shut

%LINK-5-CHANGED: Interface Serial0/1, changed state to down
Router2(config-if)#
Router2(config-if)#exit
Router2(config)#
Router2(config)#ip route 192.168.1.0 255.255.255.0 10.82.1.1
Router2(config)#ip route 192.168.3.0 255.255.255.0 10.82.2.2
Router2(config)#exit
%SYS-5-CONFIG_I: Configured from console by console
Router2#
Router2#write memory
Building configuration...
[OK]
Router2#
Router2#

การ Configure ที่ router 3

 

Router>enable
Router#
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#
Router(config)#hostname Router3
Router3(config)#
Router3(config)#interface fastethernet0/0

Router3(config-if)#ip address 192.168.3.1 255.255.255.0
Router3(config-if)#no shut

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
Router3(config-if)#
Router3(config-if)#
Router3(config-if)#exit
Router3(config)#
Router3(config)#
Router3(config)#interface serial0/0
Router3(config-if)#ip address 10.82.2.2 255.255.255.0
Router3(config-if)#no shut

%LINK-5-CHANGED: Interface Serial0/0, changed state to up
Router3(config-if)#
Router3(config-if)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0, changed state to up
Router3(config-if)#
Router3(config-if)#

Router3(config-if)#exit
Router3(config)#
Router3(config)#ip route 192.168.1.0 255.255.255.0 10.82.2.1
Router3(config)#ip route 192.168.2.0 255.255.255.0 10.82.2.1
Router3(config)#
Router3(config)#exit
%SYS-5-CONFIG_I: Configured from console by console
Router3#
Router3#write memory
Building configuration...
[OK]
Router3#
Router3#

 


ตรวจสอบสถานะการ COnfiguration IP Address ของ Router1,Router2,Router3


ด้วยการใช้คำสั่ง Show Ip interface brief


ทำการทดลอง การเชื่อมต่อด้วย Diagram ในที่นี้ สามารถทดสอบได้

ด้วยการ Ping จาก Network ID 192.168.1.0,192.168.2.0,192.168.3.0


ทดสอบด้วย การ Ping Command ของ 192.168.1.2 ซึ่งเชื่อมต่อที่ router 1
ไปยัง client ของ Router 2



ทดสอบด้วย การ Ping Command ของ client 192.168.1.2 ซึ่งเชื่อมต่อที่ router 1
ไปยัง client 192.168.3.2ของ Router 3 ผลลัพธ์มีการตอบกลับแสดงว่าเส้นทางถูกต้อง



ทดสอบด้วย การ Ping Command ของ client 192.168.2.2 ซึ่งเชื่อมต่อที่ router 2
ไปยัง client 192.168.1.2ของ Router 1 ผลลัพธ์มีการตอบกลับแสดงว่าเส้นทางถูกต้อง



ทดสอบด้วย การ Ping Command ของ client 192.168.2.2 ซึ่งเชื่อมต่อที่ router 2
ไปยัง client 192.168.3.2ของ Router 3 ผลลัพธ์มีการตอบกลับแสดงว่าเส้นทางถูกต้อง








เราจะมาทดลองเชื่อมต่อระบบเครือข่าย Wan โดยการเชื่อมต่อ 3 ระบบ


โดยเรียนรู้พื้นฐานการกำหนด เส้นทางแบบ Default Router

เพื่อให้ Router สามารถสื่อสารกัับเครื่อข่ายผ่าน subnet ที่ต่างกันได้

Diagram Network เราจะทำการเชื่อมต่อ Router1 , Router2 , Router3

และทำการกำหนดเส้นทาง การเชื่อมต่อของเครือข่ายแบบ Default Router





แสดงทิศทางการสื่อสารของ Router1 ออกไปยัง Router2,Router3



แสดงทิศทางการสื่อสารของ Router2 ออกไปยัง Router1,Router3




แสดงทิศทางการสื่อสารของ Router3 ออกไปยัง Router1,Router2

Router Port IP Address ที่กำหนด

Router1

Port Fast Ethernet 0/0

192.168.1.1

Router1

Port Serial Interface 0/0

10.82.1.1

Router2

Port Fast Ethernet 0/0

192.168.20.1

Router2

Port Serial 0/1

10.82.2.1

Router2

Port Serial 0/0

10.82.1.2

Router3

Port Serial 0/0

10.82.2.2

Router3

Port Fast Ethernetl 0/0

192.168.50.1


เราจะใช้ command เบื้องต้นเพื่อให้ router สื่อสารแบบ Default ในการทดลองนี้ดังนี้

สถานะ promt ของ Router คำสั่งที่ใช้ในในการทดลองนี้ ความหมายของคำสั่ง

Router1

(config)#

ip route 0.0.0.0
0.0.0.0
10.82.1.2
ทำการกำหนดเส้นทางการสื่อสารของ
Router 1 เพื่อให้ติดต่อกับ network ID
ใดๆ ในเครือข่ายโดยผ่านประตูทางเข้า
10.82.1.2 ของ Router 2
เพื่อให้ Router 1 --> Router 2,3

Router2

(config)#

ip route 0.0.0.0
0.0.0.0
10.82.1.1
ทำการกำหนดเส้นทางการสื่อสารของ
Router 2 เพื่อให้ติดต่อกับ network ID
192.168.1.0 โดยผ่านประตูทางเข้า
10.82.1.1 ของ Router 1
เพื่อให้ Router 2 --> Router 1

Router2

(config)#

ip route 0.0.0.0
0.0.0.0
10.82.2.2
ทำการกำหนดเส้นทางการสื่อสารของ
Router 2 เพื่อให้ติดต่อกับ network ID
192.168.50.0 โดยผ่านประตูทางเข้า
10.82.2.2 ของ Router 3
เพื่อให้ Router 2 --> Router 3

Router3

(config)#

ip route 0.0.0.0
0.0.0.0
10.82.2.1
ทำการกำหนดเส้นทางการสื่อสารของ
Router 3 เพื่อให้ติดต่อกับ network ID
ใดๆ ในเครือข่ายโดยผ่านประตูทางเข้า
10.82.2.1 ของ Router 2
เพื่อให้ Router 3 --> Router 1,2




คำสั่งที่เราต้องการเปิดให้ Router ทั้ง 3 มีขั้นตอนพื้นฐานดังนี้

การ Configure ที่ router 1 พื้นฐานพร้อมคำสั่ง Default Router

 

Router>
Router>enable
Router#

Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#
Router(config)#hostname Router1
Router1(config)#
Router1(config)#interface fastethernet0/0
Router1(config-if)#
Router1(config-if)#ip address 192.168.1.1 255.255.255.0
Router1(config-if)#no shut

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
Router1(config-if)#
Router1(config-if)#exit
Router1(config)#
Router1(config)#interface serial0/0
Router1(config-if)#
Router1(config-if)#ip address 10.82.1.1 255.255.255.0
Router1(config-if)#clock rate 64000
Router1(config-if)#no shut

%LINK-5-CHANGED: Interface Serial0/0, changed state to down
Router1(config-if)#
Router1(config-if)#exit
Router1(config)#
Router1(config)#ip route 0.0.0.0 0.0.0.0 10.82.1.2

Router1(config)#exit
%SYS-5-CONFIG_I: Configured from console by console
Router1#
Router1#
Router1#write memory
Building configuration...
[OK]
Router1#
Router1#
%LINK-5-CHANGED: Interface Serial0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0, changed state to up

 

  การ Configure ที่ router 2
 

Router>
Router>enable
Router#
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#
Router(config)#hostname Router2
Router2(config)#
Router2(config)#interface fastethernet 0/0
Router2(config-if)#
Router2(config-if)#ip address 192.168.20.1 255.255.255.0
Router2(config-if)#no shut

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
Router2(config-if)#
Router2(config-if)#exit
Router2(config)#
Router2(config)#interface serial0/0
Router2(config-if)#ip address 10.82.1.2 255.255.255.0
Router2(config-if)#no shut

%LINK-5-CHANGED: Interface Serial0/0, changed state to up
Router2(config-if)#
Router2(config-if)#
Router2(config-if)#exit
Router2(config)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0, changed state to up
Router2(config)#
Router2(config)#interface serial0/1
Router2(config-if)#
Router2(config-if)#ip address 10.82.2.1 255.255.255.0
Router2(config-if)#clock rate 64000
Router2(config-if)#no shut

%LINK-5-CHANGED: Interface Serial0/1, changed state to down
Router2(config-if)#
Router2(config-if)#exit
Router2(config)#
Router2(config)#ip route 0.0.0.0 0.0.0.0 10.82.1.1
Router2(config)#ip route 0.0.0.0 0.0.0.0 10.82.2.2
Router2(config)#
Router2(config)#exit
%SYS-5-CONFIG_I: Configured from console by console
Router2#
Router2#write memory
Building configuration...
[OK]
Router2#
Router2#
Router2#
%LINK-5-CHANGED: Interface Serial0/1, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/1, changed state to up

 

การ Configure ที่ router 3

 

Router>enable
Router#
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#
Router(config)#hostname Router3
Router3(config)#
Router3(config)#interface fastethernet0/0
Router3(config-if)#
Router3(config-if)#ip address 192.168.50.1 255.255.255.0
Router3(config-if)#no shut

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
Router3(config-if)#
Router3(config-if)#exit
Router3(config)#
Router3(config)#
Router3(config)#interface serial0/0
Router3(config-if)#
Router3(config-if)#ip address 10.82.2.2 255.255.255.0
Router3(config-if)#no shut

%LINK-5-CHANGED: Interface Serial0/0, changed state to up
Router3(config-if)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0, changed state to up
Router3(config-if)#
Router3(config-if)#exit
Router3(config)#
Router3(config)#ip route 0.0.0.0 0.0.0.0 10.82.2.1
Router3(config)#exit
%SYS-5-CONFIG_I: Configured from console by console
Router3#
Router3#write memory
Building configuration...
[OK]
Router3#
Router3#

 

 

 


ตรวจสอบสถานะการ COnfiguration IP Address ของ Router1,Router2,Router3


ด้วยการใช้คำสั่ง Show Ip interface brief


ทำการทดลอง การเชื่อมต่อด้วย Diagram ในที่นี้ สามารถทดสอบได้

ด้วยการ Ping จาก Network ID 192.168.1.0,192.168.20.0,192.168.50.0


ทดสอบด้วย การ Ping Command ของ Client 192.168.1.10 ซึ่งเชื่อมต่อที่ router 1
ไปยัง client 192.168.20.10 ของ Router 2 ผลลัพธ์ สามารถติดต่อกันได้



ทดสอบด้วย การ Ping Command ของ Client 192.168.1.10 ซึ่งเชื่อมต่อที่ router 1
ไปยัง client 192.168.50.50 ของ Router 3 ผลลัพธ์ สามารถติดต่อกันได้




ทดสอบด้วย การ Ping Command ของ Client 192.168.20.20 ซึ่งเชื่อมต่อที่ router 2
ไปยัง client 192.168.1.10 ของ Router 1 ผลลัพธ์ สามารถติดต่อกันได้

ทดสอบด้วย การ Ping Command ของ Client 192.168.20.20 ซึ่งเชื่อมต่อที่ router 2
ไปยัง client 192.168.50.50 ของ Router 3 ผลลัพธ์ สามารถติดต่อกันได้




ทดสอบด้วย การ Ping Command ของ Client 192.168.50.50 ซึ่งเชื่อมต่อที่ router 3
ไปยัง client 192.168.1.10 ของ Router 1 ผลลัพธ์ สามารถติดต่อกันได้


ทดสอบด้วย การ Ping Command ของ Client 192.168.50.50 ซึ่งเชื่อมต่อที่ router 3
ไปยัง client 192.168.20.10 ของ Router 2 ผลลัพธ์ สามารถติดต่อกันได้








dvd training

ราคาเพียง 200 บาท ฟรีค่าจัดส่ง EMS
PRASANSOFT